Brew Magicians Forum - BMF

A forum for Brew Magic users and those who love them. This forum is not affiliated with SABCO.
It is currently Mon Apr 24, 2017 3:04 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Tue Nov 11, 2014 10:19 am 
Offline
Hydrometer Jar

Joined: Wed Oct 29, 2014 6:07 am
Posts: 6
Hi folks,

We went to light up our BM for the first time today, but we're finding the burner on our HLT is only fiving us a big yellow flame. bothe the MT and the Copper are burning perfectly. Any Idea's?


Top
 Profile  
Reply with quote  
PostPosted: Fri Nov 21, 2014 1:51 pm 
Offline
Pint Glass
User avatar

Joined: Tue Mar 05, 2013 2:26 pm
Posts: 79
Location: Stamford, CT
There's a regulator reset thread on here, maybe this will help.

http://www.brewmagiciansforum.com/viewtopic.php?f=8&t=53

_________________
Always do sober what you said you would do drunk. That will teach you to keep your mouth shut. - Ernest Hemingway


Top
 Profile  
Reply with quote  
PostPosted: Fri Dec 04, 2015 2:39 pm 
Offline

Joined: Sat Apr 18, 2015 12:28 pm
Posts: 1
From the SABCO guys....you could try the check valve in the propane hose connection. I've attached a photo of this. Take a small screwdriver or piece of wire and insert it in the hose connector to free up the check valve. Then spray a little wd40 or oil in there. Once in a while this check valve can stick and restrict gas flow.



Sent from my iPhone using Tapatalk


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group