Brew Magicians Forum - BMF

A forum for Brew Magic users and those who love them. This forum is not affiliated with SABCO.
It is currently Tue Dec 12, 2017 1:57 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 11 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Wed Jun 12, 2013 10:12 am 
Offline

Joined: Tue May 07, 2013 2:11 pm
Posts: 4
OneEyedGiant wrote:
I had a VERY easy brew day on Sunday. Essentially, I inadvertently started to fill the MT with water the old way ...from the bottom. Well by filling from the bottom, it fully filled the lines. Once I got to the level of the false bottom, I shut off the valve coming from the MT and turned on the pump to fill the MT to the desired level, poured in all my grain, stirred it up, began circulating and it worked. I didn't have to prime anything. This is going to be the way I do it from now on. It was so easy it was funny.


This is pretty much what I do too. Bottom fill the MT from HLT until water hits the FB, then use pump to transfer the remaining water as I slowly mash in.

One thing I have encountered is when sparging, even with the HLT dip tube, once the water level hits the dip tube TC connection I lose the siphon. It doesn't do this when I mash in, I guess because the pump/valve is open 100% vs maybe 30% when sparging. Anyone else encounter this? I've replaced the TC gasket, ensured everything else is snug, and it's happened 4/4 times I've brewed on my system (Dec 2008).


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group